UXWizz
Search…
⌃K

No data is being recorded

After a successful installation new sessions and data should be tracked and available immediately in your dashboard (after a refresh).

Problem:

No data is being sent to the dashboard.

Possible causes and solutions

  1. 1.
    The tracking snippet was not included on the tracked website (check the source code of the page to make sure it was added).
  2. 2.
    Wrong dashboard server path setting (after installation or a domain name change). Go to your dashboard Settings->Tracking and click "Reset" next to the "Server path" setting or manually set it to the URL of your dashboard.
  3. 3.
    Caching issues: if you added the tracking script but it's not visible in the source code, the old page might be cached (see clearing the cache below). You should also clear the cache after changing any settings (such as after fixing the server path).
The easiest way to debug tracking issues is to open the Network tab in the browser dev tools (F12) and check if, in order:
  1. 1.
    The JS tracking file was loaded.
  2. 2.
    The createClient.php request was successful.

Clearing the cache

Depending on your how your website is built, there are multiple caches that might need to be cleared:
  1. 1.
    Browser cache - Refresh using CTRL+SHIFT+R (or use your browser's settings to clear the cache for the tracked website and your dashboard).
  2. 2.
    CDN cache (such as Cloudflare) - Go to your CDN and Purge the cache for the tracked website and your dashboard (if behind Cloudflare).
  3. 3.
    WordPress plugin cache (if you use plugins like WP Rocket or W3 Total Cache) - Clear the website cache from the plugin settings.
  4. 4.
    Server cache - Depending on the web server used, you might have an additional caching layer still serving the old JS tracking file. Open the file URL directly in the browser to see if any setting looks outdated.