UXWizz
Search
⌃K

License says "invalid"

Problem:

Setting your license key in the dashboard doesn't work, resulting in a red message with the text "Invalid license key".

Cause:

There are two common causes:
  1. 1.
    You have the wrong variant installed (e.g. WordPress instead of regular, or trying to update a regular version trial to an Agency version).
  2. 2.
    Your server can not contact the UXWizz license server due to outdated HTTPS certificates.
If something doesn't work as expected, the quickest way to see what the problem is is to check your server's error.log file for more information.

Solution:

For case #1 (wrong version) please contact support, and you will receive two files to replace in your UXWizz installation to force-request the correct version when checking the license.

For case #2: The requests to the license server are blocked.

This can happen for several reasons:
  1. 1.
    A firewall or security plugin on your server is blocking external requests.
  2. 2.
    The request fails because the HTTPS certificates list is outdated on your server.
Make sure there is no firewall blocking outgoing requests from your server to the UXWizz download server (allow requests to the license-api.uxwizz.com domain)
The PHP ca-bundle.crt file might be outdated on your server.
More specifically, it might miss the "ISRG" certificate entry (which is used by Let's Encrypt that is used for the HTTPS certificate on the UXWizz license server). The ca-bundle used is specified in php.ini in the [openssl] section:
If a path is set, you can try updating the certificates list file with a recent one available online: https://curl.se/docs/caextract.html ( cacert.pem ) Here is the same one, but with the same file name as you need: https://raw.githubusercontent.com/bagder/ca-bundle/master/ca-bundle.crt​
You should backup the existing file ca-bundle.crt file before replacing.
You can also try to update the OS-level list of certificates (eg. sudo update-ca-certificates if you have an Ubuntu server).